California

Sprocket rocket #1

2 1
Shooting my first film with the sprocket rocket looked so easy breezy but I only got two successful shot here.

Here’s why:
1. I always failed to check the right settings of the camera. I have found out that I shot most of the film on a B-mode (long exposure); which I think was accidentally moved while the camera was in my bag.
2.  And aperture was set to cloudy too.

So this is how I only got two great landscape panorama from my first roll. Better luck next time. 😀

How is everyone btw? Hope you all are having a great weekend!

Camera: Lomography Sprocket Rocket
Film: Lomography CN 800 35mm
Processing: Color Negative C41 (panorama with holes)

9 Comments

  1. You have more patience than I do. I’ve had enough film photography for my lifetime. I much prefer digital as if a shot doesn’t turn out, it doesn’t break the bank. lol!

    I do like your top image. Almost a mysterious feel. 🙂

    Like

    • Ha, I know… but I was so sad ‘coz it cost a lot to develop the film from this camera…Thanks Ed.

      Like

  2. Ah, the unintended ‘B’ mode… hate when that happens! but what a fun camera! 😀 I kind of like the cold and shady effects. looks cool!

    Like

    • Oh, that could be the film that gives it the cold shady effect. 🙂 I haven’t tried it with other film so I’ll see if it’s really the camera or the film. 🙂 thanks Ksenia.

      Btw, pls. let me know if you get the card I’ve sent you a few weeks ago.

      Like

    • Thanks J. I think it is and I also like the dreamy effect. 🙂

      Like

Comments are closed.